Comment installer Diaspora sur debian

Diaspora est un réseau social décentralisé. La différence avec les autres réseaux sociaux c'est qu'il se trouve sur plusieurs serveurs. Comme pour les emails, ceux-ci communiquent entre eux.

Jusqu'à aujourd'hui l'installation de diaspora été assez compliqué et il fallait de nombreuses lignes de code et des bonnes compétences système. Depuis peu l'installation de diaspora a été facilité car des paquets debian ont été mis à disposition.

Attention cet installeur est encore expérimental. Je n'ai encore reçu aucun retour de quelqu'un qui l'a expérimenté avec success.

En une ligne de commande vous pouvez installer diaspora sur debian.

Pour installer avec une base de donnée postgress
apt-get install diaspora-installer

Pour installer avec une base de donnée mysqlapt-get install diaspora-installer
apt-get install diaspora-installer-mysql
Voila

plus d'informations

Mise à niveau à Jessie debian 8 pas facile

Debian est la distribution linux la plus standard. Elle est réputé pour sa robustesse et sa stabilité. Mais un passage à debian 8 n'est pas si facile malgrés l'abondante aide .

nano /etc/apt/sources.list

remplacement de wheezy par jessie.

apt-get update
apt-get upgrade

mais ...
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 console-setup-linux : Dépend: keyboard-configuration (= 1.123) mais 1.88 est installé
 libapache2-mod-php5 : Dépend: php5-common (= 5.6.13+dfsg-0+deb8u1) mais 5.4.45-0+deb7u1 est installé
 lsof : Dépend: libperl4-corelibs-perl mais il n'est pas installé ou
                 perl (< 5.12.3-7) mais 5.20.2-3+deb8u1 est installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.

Comment faire ? Réinstaller le système à partir de zéro ou bien chercher chercher chercher une solution. Avez vous une piste ?

...

Voici la solution de  jp_morfin chez pod.g3l.org (merci encore!)
mv /dev/shm /dev/shm.backup
apt-get -f install
apt-get update
apt-get upgrade

...
Bon il y avait un owncloud qui ne fonctionne plus, openpanel n'avait plus de dépôt pour cette version debian. Il reste encore du travail